<!DOCTYPE html>
<html dir="ltr">
<head>
	<meta charset="utf-8" />
    <base href="http://www.finatics.com/103-reshad-jones-returns-to-the-field" />    
    <script>
    var themeHasJQuery = !!window.jQuery;
</script>
<script src="/templates/finatics2017/jquery.js?version=1.0.672"></script>
<script>
    window._$ = jQuery.noConflict(themeHasJQuery);
</script>
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
<script src="/templates/finatics2017/bootstrap.min.js?version=1.0.672"></script>
<!--[if lte IE 9]>
<script src="/templates/finatics2017/layout.ie.js?version=1.0.672"></script>
<link rel="stylesheet" href="/templates/finatics2017/layout.ie.css?version=1.0.672" media="screen"/>
<![endif]-->
<script src="/templates/finatics2017/layout.core.js?version=1.0.672"></script>
<script src="/templates/finatics2017/CloudZoom.js?version=1.0.672" type="text/javascript"></script>
    
    <meta http-equiv="content-type" content="text/html; charset=utf-8" />
	<meta name="keywords" content="Finatics, Miami, Dolphins, Tailgate, Tailgating, Party, East, 15, Tailgaters, Best, Fans, Fan, News" />
	<meta name="author" content="Finatic Dave" />
	<meta name="description" content="Finatics.com - The ORIGINAL Miami Dolphins FINATICS" />
	<meta name="generator" content="Joomla! - Open Source Content Management" />
	<title>Finatics - Reshad Jones Returns to the Practice Field</title>
	<link href="/favicon.ico" rel="shortcut icon" type="image/vnd.microsoft.icon" />
	<link href="/index.php?option=com_ajax&plugin=arkbootstrap&format=json" rel="stylesheet" type="text/css" media="null" attribs="[]" />
	<link href="/index.php?option=com_ajax&plugin=arktypography&format=json" rel="stylesheet" type="text/css" media="null" attribs="[]" />
	<link href="//cdnjs.cloudflare.com/ajax/libs/jquery.swipebox/1.3.0.2/css/swipebox.min.css" rel="stylesheet" type="text/css" />
	<link href="http://www.finatics.com/media/editors/arkeditor/css/squeezebox.css" rel="stylesheet" type="text/css" />
	<link href="/modules/mod_phoca_facebook_comments/assets/style.css" rel="stylesheet" type="text/css" />
	<script src="/templates/finatics2017/js/jui/jquery.min.js?93d5437d706cba3286ad7e9b5c9ed371" type="text/javascript"></script>
	<script src="/templates/finatics2017/js/jui/jquery-noconflict.js?93d5437d706cba3286ad7e9b5c9ed371" type="text/javascript"></script>
	<script src="/media/jui/js/jquery-migrate.min.js?93d5437d706cba3286ad7e9b5c9ed371" type="text/javascript"></script>
	<script src="/templates/finatics2017/js/jui/bootstrap.min.js?93d5437d706cba3286ad7e9b5c9ed371" type="text/javascript"></script>
	<script src="//cdnjs.cloudflare.com/ajax/libs/jquery.swipebox/1.3.0.2/js/jquery.swipebox.min.js" type="text/javascript"></script>
	<script src="http://www.finatics.com/media/editors/arkeditor/js/jquery.easing.min.js" type="text/javascript"></script>
	<script src="http://www.finatics.com/media/editors/arkeditor/js/squeezebox.min.js" type="text/javascript"></script>
	<script type="text/javascript">
(function()
				{
					if(typeof jQuery == 'undefined')
						return;
					
					jQuery(function($)
					{
						if($.fn.squeezeBox)
						{
							$( 'a.modal' ).squeezeBox({ parse: 'rel' });
				
							$( 'img.modal' ).each( function( i, el )
							{
								$(el).squeezeBox({
									handler: 'image',
									url: $( el ).attr( 'src' )
								});
							})
						}
						else if(typeof(SqueezeBox) !== 'undefined')
						{
							$( 'img.modal' ).each( function( i, el )
							{
								SqueezeBox.assign( el, 
								{
									handler: 'image',
									url: $( el ).attr( 'src' )
								});
							});
						}
						
						function jModalClose() 
						{
							if(typeof(SqueezeBox) == 'object')
								SqueezeBox.close();
							else
								ARK.squeezeBox.close();
						}
					
					});
				})();
	</script>
	<script type="text/javascript">
function MySpaceGetThis(U)
{
    var targetUrl = 'http://www.myspace.com/index.cfm?fuseaction=postto&u=' + encodeURIComponent(U);
    window.open(targetUrl, 'ptm', 'height=450,width=440').focus();
}
</script>
	<meta property="fb:app_id" content="350012125330355" />
        <link rel="stylesheet" href="/templates/finatics2017/css/bootstrap.min.css?version=1.0.672" media="screen" />
            <link rel="stylesheet" href="/templates/finatics2017/css/template.min.css?version=1.0.672" media="screen" />
            <script src="/templates/finatics2017/script.js?version=1.0.672"></script>
    
</head>
<body class=" bootstrap bd-body-6  bd-pagebackground-14 bd-margins">
    <header class=" bd-headerarea-1 bd-margins">
        <section class=" bd-section-3 bd-tagstyles" id="section3" data-section-title="">
    <div class="bd-container-inner bd-margins clearfix">
        <div class=" bd-layoutbox-3 bd-no-margins clearfix">
    <div class="bd-container-inner">
                    <div data-affix
     data-offset=""
     data-fix-at-screen="top"
     data-clip-at-control="top"
     
 data-enable-lg
     
 data-enable-md
     
 data-enable-sm
     
     class=" bd-affix-2 bd-no-margins bd-margins ">
        <nav class=" bd-hmenu-1 " data-responsive-menu="true" data-responsive-levels="">
                        
                <div class=" bd-responsivemenu-11 collapse-button">
    <div class="bd-container-inner">
        <div class="bd-menuitem-10 ">
            <a  data-toggle="collapse"
                data-target=".bd-hmenu-1 .collapse-button + .navbar-collapse"
                href="#" onclick="return false;">
                    <span>Menu</span>
            </a>
        </div>
    </div>
</div>
                <div class="navbar-collapse collapse">
            <div class=" bd-horizontalmenu-2 clearfix">
    <div class="bd-container-inner">
                
<ul class=" bd-menu-3 nav nav-center nav-pills" >
                        
        <li class=" bd-menuitem-3 bd-toplevel-item  item-101  current">
<a class="  active" href="/"><span>Home</span></a></li>                        
        <li class=" bd-menuitem-3 bd-toplevel-item  item-164 ">
<a href="http://www.facebook.com/finaticscom"><span>Finatics on Facebook</span></a></li>                        
        <li class=" bd-menuitem-3 bd-toplevel-item bd-submenu-icon-only item-265  deeper parent">
<a href="/miami-dolphins-news"><span>Miami Dolphins News</span></a>        <div class="bd-menu-4-popup">
                            <ul class=" bd-menu-4">
                                            
        <li class=" bd-menuitem-4 bd-sub-item item-271 ">
<a href="/miami-dolphins-news/2017-schedule"><span>2017 Schedule</span></a></li>                        
        <li class=" bd-menuitem-4 bd-sub-item item-165 ">
<a href="/miami-dolphins-news/phins-com-network"><span>Phins.com Network</span></a></li>                        
        <li class=" bd-menuitem-4 bd-sub-item item-168 ">
<a href="/miami-dolphins-news/yardbarkers"><span>Yardbarkers</span></a></li>                        
        <li class=" bd-menuitem-4 bd-sub-item item-247 ">
<a href="http://www.miamidolphins.com"><span>Dolphins.com</span></a></li></ul></div></li>                        
        <li class=" bd-menuitem-3 bd-toplevel-item bd-submenu-icon-only item-281  deeper parent">
<a><span>About Us</span></a>        <div class="bd-menu-4-popup">
                            <ul class=" bd-menu-4">
                                            
        <li class=" bd-menuitem-4 bd-sub-item item-108 ">
<a href="http://www.finatics.com/1"><span>Who Are The Finatics?</span></a></li>                        
        <li class=" bd-menuitem-4 bd-sub-item item-282 ">
<a href="/about-us/the-tailgate"><span>The Tailgate</span></a></li>                        
        <li class=" bd-menuitem-4 bd-sub-item item-272 ">
<a href="/about-us/tailgate-trophies"><span>Tailgate Trophies</span></a></li>                        
        <li class=" bd-menuitem-4 bd-sub-item item-314 ">
<a href="/about-us/sites-we-recommend"><span>Sites We Recommend</span></a></li></ul></div></li>                </ul>    </div>
</div>            
                </div>
                    </nav>
        </div>
    	
		<div class=" bd-parallaxbackground-2 bd-parallax-bg-effect" data-control-selector=".bd-logo-2"><a class=" bd-logo-2 bd-imagescaling bd-imagescaling-1 " href="/">
<img class=" bd-imagestyles-18" src="http://www.finatics.com/templates/finatics2017/images/designer/ab1db926ec357544cfc5b19e5fa54ee7_Finatics2015Transparent.gif"
 alt="Finatics">
</a></div>
    </div>
</div>
    </div>
</section>
</header>
	
		<div class=" bd-stretchtobottom-3 bd-stretch-to-bottom" data-control-selector=".bd-contentlayout-6">
<div class="bd-contentlayout-6  bd-sheetstyles-2  bd-no-margins bd-margins" >
    <div class="bd-container-inner">

        <div class="bd-flex-vertical bd-stretch-inner bd-contentlayout-offset">
            
            <div class="bd-flex-horizontal bd-flex-wide bd-no-margins">
                
                     <aside class="bd-sidebararea-3-column hidden-sm hidden-xs bd-no-margins  bd-flex-vertical bd-flex-fixed ">
                <div class="bd-sidebararea-3 hidden-sm hidden-xs bd-no-margins bd-flex-wide  bd-margins">
                    
                    <div class=" bd-joomlaposition-1 bd-no-margins clearfix" >
            <div class=" bd-block-7 bd-own-margins " >
            
    <div class="bd-blockcontent bd-tagstyles">
        <div class="mod_facebook_page_display " style="max-width: 350px;">
   <div class="fb-page" 
        data-href="https://www.facebook.com/finaticscom" 
        data-tabs="timeline" 
        data-width="350" 
        data-height="2500" 
        data-small-header="true" 
        data-adapt-container-width="true" 
        data-hide-cover="true" 
        data-hide-cta=""
        data-show-facepile="false">
        <div class="fb-xfbml-parse-ignore">
          <blockquote cite="https://www.facebook.com/finaticscom">
            <a href="https://www.facebook.com/finaticscom">Finatics</a>
          </blockquote>
        </div>
      </div>
</div>	
<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.8&appId=350012125330355";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>    </div>
    
</div>
        </div>                    
                </div>
            </aside>
                        <div class="bd-flex-vertical bd-flex-wide bd-no-margins">
                    

                    <div class=" bd-layoutitemsbox-23 bd-flex-wide bd-no-margins">
    <div class=" bd-content-6">
    

<div class=" bd-blog-3 " itemscope itemtype="http://schema.org/Article" >
    <div class="bd-container-inner">
    
                    <div class=" bd-grid-6 bd-margins">
          <div class="container-fluid">
            <div class="separated-grid row">
                <div class="separated-item-38 col-md-12 ">
                    
                    <div class="bd-griditem-38">
            
        <article class=" bd-article-3">
            <h2 class=" bd-postheader-3"  itemprop="name">
                        <a href="/103-reshad-jones-returns-to-the-field">
                Reshad Jones Returns to the Practice Field            </a>
            </h2>
	
		<div class=" bd-layoutbox-8 bd-no-margins clearfix">
    <div class="bd-container-inner">
        <div class=" bd-posticondate-4 bd-no-margins">
    <span class=" bd-icon bd-icon-41"><span><time datetime="2017-08-04T13:42:54+00:00" itemprop="dateCreated">Created: 04 August 2017</time></span></span>
</div>
	
		<div class=" bd-posticonauthor-5 bd-no-margins">
    <span class=" bd-icon bd-icon-43"><span>Written by Finatic Dave</span></span>
</div>
	
			
			
		    </div>
</div>
	
		<div class=" bd-layoutbox-10 bd-no-margins clearfix">
    <div class="bd-container-inner">
        	
		<div class=" bd-postcontent-3 bd-tagstyles  bd-contentlayout-offset"  itemprop="articleBody">
    <p><span style="font-size: 12.16px;"><a href="/images/rJones.jpg" class="jh-image-popup-swipebox"><img src="/images/rJones.jpg" alt="" width="30%" style="float: left;" /></a>In light of the Tannehill situation, we thought we whod focus on something positive today. &nbsp;Reshad Jones was activated on Wednesday and returned to the training camp practice field. &nbsp;Here is what he had to say after his first training camp practice...</span></p>
<p>(How’d it feel just to be out there?) – “It felt good to put the pads on. I haven’t had the pads on in a while. It feels good to be out here and run around with my teammates and get my feet wet a little bit.”</p>
<p>(It didn’t seem like you were limited in anything.) – “No. It was straight go. Like I said, it felt good for me. It’s been seven or eight months since I’ve had pads on. It’s a fun experience. It feels good.”</p>
<p>(How did you tweak the calf?) – “Working out early on with my trainer. It was something minor.”</p>
<p>(They seemed like they wanted to error on the side of caution with you?) – “Yes. They just wanted to be careful. Calves are kind of tricky. When you’re coming back off of them, you can pull it and be out for a long time. They just want to be careful.”</p>
<p>(How did it respond today? Did you think about it at all?) – “No, not at all. It felt pretty good.”</p>
<p>(How do you like that group you are playing with back there with the DBs?) – “We’ve got some talent back there. We have some veteran guys in Nate Allen and T.J. (McDonald) that we brought in that have played a lot of football around this league. It feels good to be back there and kind of communicating and running around with those guys.”</p>
<p>(Did you feel like you were riding a bike leading the guys back there? How did it feel today?) – “It felt great. This is what I do. I’ve been playing in this league for a while. It just felt good to come back out and sweat a little bit, get my feet wet. I feel comfortable.”</p>
<p>(You busted up a running play in team drills. That had to feel pretty nice.) – “Yes, it felt good to get in that backfield for the first time. It felt good.”</p>
<p>(One of the issues last year was tackling. How do you, as a player, alone make that better? Obviously you weren’t there for the second half of the season.) – “You just have to work at it in practice. This is a great time at camp to work on your angles, communication, everybody running to the ball and different things like that. Tackling doesn’t just start on Sunday. It starts out here on the practice field. That’s where you get better at it.”</p>
<p>(How well did you understand the defense last year compared to this year?) – “We’re a lot more comfortable now. It’s the second year up under the belt (with the) same defense. We’ve got veteran guys in. We brought in a guy like ‘L.T.’ (Lawrence Timmons who is) a championship guy, or a champion that knows what it looks like and knows how to get it done. We just have to build off that energy.”</p>
<p>(How much are you itching to get this thing going?) – “I’m ready. I’m excited. I feel good. We did some great things last year but I think the ceiling is very high for this team. We just have to continue to put the work in out here. The sky is the limit for us.</p> <script> jQuery( document ).ready(function() { jQuery( ".jh-image-popup-swipebox" ).swipebox(); });</script></div>
    </div>
</div>
        </article>
        <div class="bd-container-inner"></div>
        
                        </div>
                    </div>
                </div>
            </div>
        </div>
    </div>
</div>

</div>
	
		    	
		    
        <div class=" bd-joomlaposition-13 bd-no-margins clearfix" >
            <div class=" bd-block-8 bd-own-margins " >
            
    <div class="bd-blockcontent bd-tagstyles">
        <div id="phoca-facebook-comments">
<div class="pfbcs">
<fb:send href="http://www.finatics.com/103-reshad-jones-returns-to-the-field" font=""></fb:send></div>
<div class="pfbct">
<a href="http://twitter.com/share" class="twitter-share-button"  data-count="horizontal" data-url="http://www.finatics.com/103-reshad-jones-returns-to-the-field" data-via="1">Tweet</a><script type="text/javascript" src="http://platform.twitter.com/widgets.js"></script></div>
<div class="pfbcp">
<g:plusone size="medium"></g:plusone><script type="text/javascript" src="http://apis.google.com/js/plusone.js"></script></div>
<div class="pfbcm">
<a href="javascript:MySpaceGetThis('http://www.finatics.com/103-reshad-jones-returns-to-the-field')"><img src="http://cms.myspacecdn.com/cms//ShareOnMySpace/Myspace_btn_Share.png" style="border:none;" alt="Share on Myspace" /></a></div>
<div class="pfbcl">
<iframe src="http://www.facebook.com/plugins/like.php?app_id=133499630061802&amp;href=http://www.finatics.com/103-reshad-jones-returns-to-the-field&amp;send=false&amp;layout=standard&amp;width=100&amp;show_faces=0&amp;action=like&amp;colorscheme=light&amp;font&amp;height=26"  style="border:none; overflow:hidden; width:100px; height:26px;" ></iframe></div>
<script>(function(d){
  var js, id = 'facebook-jssdk'; if (d.getElementById(id)) {return;}
  js = d.createElement('script'); js.id = id; js.async = true;
  js.src = "//connect.facebook.net/en_US/all.js#xfbml=1&amp;appId=350012125330355";
  d.getElementsByTagName('head')[0].appendChild(js);
}(document));</script><div class="pfbcc"><fb:comments href="http://www.finatics.com/103-reshad-jones-returns-to-the-field" num_posts="10" data-width="100%" ></fb:comments></div><div class="cb"></div></div>
    </div>
    
</div>
        </div>
        </div>

                    
                </div>
                
            </div>
            
        </div>

    </div>
</div></div>
	
		<footer class=" bd-footerarea-1 bd-margins">
        <section class=" bd-section-2 bd-tagstyles" id="section2" data-section-title="">
    <div class="bd-container-inner bd-margins clearfix">
        <div class=" bd-layoutcontainer-28 bd-columns bd-no-margins">
    <div class="bd-container-inner">
        <div class="container-fluid">
            <div class="row ">
                <div class=" bd-columnwrapper-60 
 col-md-3
 col-sm-6
 col-xs-12">
    <div class="bd-layoutcolumn-60 bd-column" ><div class="bd-vertical-align-wrapper">    </div></div>
</div>
	
		<div class=" bd-columnwrapper-61 
 col-md-3
 col-sm-6
 col-xs-12">
    <div class="bd-layoutcolumn-61 bd-column" ><div class="bd-vertical-align-wrapper">    </div></div>
</div>
	
		<div class=" bd-columnwrapper-62 
 col-md-3
 col-sm-6
 col-xs-12">
    <div class="bd-layoutcolumn-62 bd-column" ><div class="bd-vertical-align-wrapper">    </div></div>
</div>
	
		<div class=" bd-columnwrapper-63 
 col-md-3
 col-sm-6
 col-xs-12">
    <div class="bd-layoutcolumn-63 bd-column" ><div class="bd-vertical-align-wrapper">    
        <div class=" bd-joomlaposition-5 clearfix" >
            </div>
        </div></div>
</div>
            </div>
        </div>
    </div>
</div>
	
		<div class=" bd-pagefooter-1 hidden-md hidden-sm hidden-xs hidden-lg">
    <div class="bd-container-inner">
        
            <a href='http://www.themler.com/joomla-templates' target="_blank">Joomla Template</a> created with <a href='http://themler.com' target="_blank">Themler</a>.
    </div>
</div>
    </div>
</section>
</footer>
	
		<div data-smooth-scroll data-animation-time="250" class=" bd-smoothscroll-3"><a href="#" class=" bd-backtotop-1 ">
    <span class="bd-icon-66 bd-icon "></span>
</a></div>
</body>
</html>